
                          
Book’em! 4.0 QuickStart
© 2002 Outside Technology All Rights Reserved

Book’em! runs on Windows and Macintosh computers with an identical feature set. This guide covers both versions, and both platforms 
are represented in the illustrations.

Installation and Log-In

Windows

If you have the CD-ROM, open the CD-ROM drive through My Computer. Open the appropriate folder (Single User or 
Client_Server) and double-click the installer.
If you downloaded a demo from the internet, simply double-click the .EXE.
It is recommended that files be installed to the default location selected by the Installer, so that upgrades done later will work 
easily.

Macintosh

If you have the CD-ROM, open the appropriate folder (Single User or Client_Server) and double-click the installer.
If you downloaded a demo from the internet, simply double-click the installer.
It is recommended that files be installed to the default location selected by the Installer, so that upgrades done later will work 
easily.

Client-Server

Besides the Book’em! CD-ROM disk, you also received a 4D Server CD-ROM from 4D, Inc. Do not install from the 4D 
Server disk! A correctly configured version of 4D Server and 4D Client is installed by the Book’em! disk.
You will need to enter the 4D Server serial number from the card you received from 4D, Inc. the first time you start 4D Server. 
If you have purchased more than 2 user licenses, you may obtain expansion pack serial numbers from 4D’s website. Go to 
http://www.4d.com/support/registration/Regform.html to register your Server license and obtain expansion serial numbers. 

Starting the Program

On Macintosh, just double-click Book’em! (or 4D Client). If you like, create an alias for the desktop or Apple Menu, but don’t 
move the actual file out of the Book’em! folder.
On Windows, open it from the Programs section of the Start Menu or the shortcut on the desktop.
With all versions and on all computers, the Book’em! folder must remain intact -- don’t move files out.

http://www.4d.com/support/registration/Regform.html
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Log-In

To enter the database, select the user name, enter the password, and click OK.
The  demo datafile has 2 sample users entered.
Dave has no password. Just select and click OK, or double-click the name.
Administrator has the password admin. The administrator has some extra privileges, such 
as the ability to add users, set system preferences, run a full data dump, rebuild indexes, etc.
When you create your real datafile you may create the users you need. See "Administration" 
on page 2

The Demo Datafile

Book’em! comes with some sample data: phony events, customers, staff, etc. Use this demo data to 
experiment and learn the program. Test different strategies of organizing your events. Since it will 
all be deleted anyway, this is the time to make mistakes.

One of the sample events of the Introductory Class type and one River Trip contains several reservations. Start exploring with 
either of these.
When a recurring master is clicked, only future events are shown. Control-clicking (Windows) or command-clicking (Mac) 
displays events of the past 30 days. Control-alt-clicking (Windows) or command-option-clicking (Mac) shows all past events. 
In the demo version, to ensure that events are visible on a simple click, the program checks to see that no events are more than 
5 days old. If any are, all events are automatically assigned a random date in the near future. Please be assured that this is not a 
bug. It is present only when using the demo datafile to avoid the possibility that you may see an empty list when trying to find 
an event!
When you are ready, choose “Create Real Datafile” from the Financial Menu at the Home screen to delete all of the sample 
data and set things up for your real entries.
After you create your real datafile, it will run for 30 days without restriction before it asks for entry of your serial number. 
Please be sure you obtain your serial number before this happens. Serial numbers may be obtained once you have tried 
Book’em! and know you want to keep it. 

Registering Book’em!

To register and obtain your serial number, open Edit Return Address from the File menu at the Home screen.
Click Request Serial Number.
Enter the number of users you need, and select the optional modules you want to purchase.
Click Send Serial No. Request. If you've set up email it'll be sent direct. If not it'll create a file that you can attach and send to 
register@outsidetech.com. 
If you have already arranged payment, a registration file will be returned via email within 24 hours. If not, we’ll contact you. 
Current pricing information may be found at http://www.outsidetech.com/BkmPrice.html, and purchase arrangements may 
be made by emailing salesinfo@outsidetech.com or phoning (888) 7-BOOKEM (726-6536).

General Setup

Let’s start with a few basic settings and entries.

Administration

This area is available from the File menu at the Home screen. Users tagged as administrators may set password parameters, 
add and delete users, and assign and modify passwords and priviledges.
Administrators have additional powers that non-admins don’t have, such as modifying program-wide preference settings, 
rebuilding indexes, running a data dump, and using the search and replace function on a selection of records.
At least one user must be tagged as administrator, but there’s no upper limit to the number of users that may be. Remember 
that any administrator may control access to the program by all others.

http://www.outsidetech.com/BkmPrice.html
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Preferences

Although this is part of basic setup, it is recommended that you skip this section for now and come back to it after you have experimented 
a bit and feel comfortable with creating events and taking reservations.

The Preferences area is available from the File menu at the Home screen. Some of the settings are interface settings that apply to the user 
that’s logged in. In addition, administrators have access to program setup functions. Most of the settings are self-explanatory. In this 
manual we’ll just take a look at a few items that require some clarification.

The Reservations Page

1. Click on Recurring Shows Events...
If set to zero, when a master event is clicked at the 
Home screen, events starting today or later are 
displayed. Enter a positive number to have X number 
of past days’ events displayed.
2. Expect Others
If you want to list the names of all people in a party, 
and keep records for them in the Customer database, 
mark this option. If you list only the reserving person, 
deselect it. This setting may be overridden for any 
reservation by changing the quantity of the invoice’s 
line item.
3. Carryover Addresses
When creating a new customer record for an 
additional person in a party, Book’em! will auto-enter the surname and address info of the primary reserver if the checkbox on 
the Reservation Creator is marked. The preference sets the default state of that checkbox.
When the carryover address feature is used, you may choose to set that record’s Mail Pref to Don’t Send Anything (or 
something else) to avoid sending duplicate mail to the same household.

The Communications Page

1. Customers Mail Preference
Every Customer record contains a Mail Preference 
setting. You may choose: All Mail, All Except Promos, 
Confirmations Only, or Don’t Send Anything.
When you are printing a mail merge letter to a 
selection of records, Book’em! will respect the setting.
The Default Mail Preference has two functions:
a. If the Save Default Mail Pref to New Records 
checkbox is marked, every new record in the Customer 
table will default to it. (The exception is the Carryover 
Address setting -- see above.)
b. If a Customer record has not been assigned a Mail 
Preference, the Default will apply when printing. This 
allows you to “float” the behavior based on the mailing.

2. Validate Non-US/Canada Addresses with no State or Zip
When printing hard copy letters or spooling labels, Book’em! will ignore records without a valid address. Normally, to be 
deliverable, an address, a city, state, and zip (postal code) is required. If this checkbox is marked, records with a country other 
than US or Canada are given more slack and the state and zip are not required.
3. SMTP Server 
The SMTP Server is your send email server address, as provided by your ISP. You can copy this from account settings in your 
email program. The Account Email Address is the address that recipients will reply to, and will also receive any undeliverable 
bounces. These two addresses must be entered or none of the email features will work.
4. Send Email if Email Address Exists
Makes email the preferred method of communication if the record has a validated email address. The setting is available when 
setting up a mailing; this is the default.
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Master Events Setup

Book’em! handles events through a template system. The system’s goals are speed, flexibility, and logical organization.

Recurring Event Masters are described by a name, a location and departure point, a cost, a size limit (number of reservations), a 
duration in days, and start and end times. 

Using the Recurring Master definition, individual events may be created simply by clicking a date on a calendar. Any of the 
characteristics may then be modified, although the event will always be found through the Master it was created by. If the Master is 
changed later it will not affect event records that already exist, although you will have the option of automatically updating future 
events. Likewise, as reservations are made for events, specific defaults carried over from the Master may be changed for each customer.

Creating Recurring Masters

5. Click the ‘Add Master’ Button on 
Book’em!’s Home screen
This will create an event definition which you 
may use to generate actual events. All of the 
settings are flexible defaults and may be 
modified for any occurrence. 
The Master definitions allow automated 
schedule creation and keep your schedule 
organized. They do not lock you into rigid 
boundaries.
6. When the Recurring Events Window 
opens, type the name of the event. 
This name (and other entries to follow) will 
appear in letters and printed reports, so use 
the name that you want to present to your 
customers and be sure to spell accurately. 
Capitalization is automatic throughout 

Book’em!, just type in lowercase.
Optionally, you may assign this master to a category. Depending on the nature of your program this may be helpful.
7. Press the TAB key and enter the name of the location.
Press the TAB key again.
Always use the TAB key to move from field to field. If the field 
TABbed into already contains text it is highlighted and anything you 
type will replace the old contents.
Book’em tracks user days by the Location record; this is where the 
event actually occurs. Use the Departure field for the place where 
participants are to meet you. Info from the Departure is used for 
confirmation letters.
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8. Would you like to create a record for the location? Yes!
Book’em! must have a “Locations” record for any Event Location or Departure.
9. Type or paste directions to the event’s location. TAB.
Directions and maps may be printed on confirmation letters. You can come back 
and enter this later, if you like. 
10. Paste a map to the location.
JPEG is the recommended format, especially if confirmations might be sent as 
email. Keep the file sizes small for good performance. The map may be entered 
later.

Any given map need only be pasted once. Once a 
map has been entered, it will be available to other 
records by clicking the Select From Library button.
11. Click the ‘Save’ button to return to the 
Recurring Master.
Once you’ve saved a record for a location it will be 
available from the Location and Departure popups.
12. Enter the event size.
A different limit may be set for any individual 
occurrence of this event type, and you may choose 
to override the limit in individual cases. Enter 0 if 
there is no limit.
13. Enter the event cost.
This is the default full price for this event type. A 
different cost may be set for specific occurrences, 
and you may charge whatever you like for any individual reservation by changing the amount on the invoice.  Also, you may 
define discounts from the Financial menu at the Home screen.
14. Enter the length of the event in days
15. Enter the event’s usual start and end time.
You may enter 24-hour time, or 12-hour time with a ‘p’ appended to afternoon times. Typing either 14.45 or 2.45p will enter 
2:45 PM. The end time is calculated.
16. Select the event’s Confirmation Letter
You may edit the selected letter by clicking the button or write a new one by selecting Create New from the popup menu.
Other options available on the Event Master

•  Pick-Up Itinerary is a list of shuttle bus pick-up points and each one’s number of minutes from ‘home.’ If an itinerary is 
defined you can select a pick-up point for each reservation and generate bus rosters.
•  Not Currently Offered maintains a record for an obsolete event so customer histories are maintained, but keeps it off 
current lists.
•  Don’t Count User Days keeps reservations for this event from being counted on the location’s User Day Report.
•  Difficulty can be used to compare against a customer’s Skill Level.
•  Sessions allows individual non-consecutive days to be scheduled. A class may be scheduled to meet, for example, 
Tuesdays and Thursdays for six weeks.
•  Destinations can be hotels, campgrounds, restaurants, etc. that you want to create rosters for.  A record must exist in 
the Destinations table to be added to the list.
•  A Description of the event may be entered that may be viewed by clicking the Description button on the Home 
screen. This description will also be used to generate web pages when that feature is available.

17. Click ‘Save’ to save the record and return to the Home screen.
This Master template may now be used to create events.

Modifying Recurring Masters

A Recurring Master may be modified by selecting it from the list and then clicking the Edit Master button. When you are 
finished with your changes Book’em! will ask if you’d like to have the changes applied to existing future occurrences, as of an 
effective date that you specify. Only events which had the old default value will be updated. For example, if there were 20 
upcoming events of this type and two of them had a different location, changing the location of the master would change the 
location of only 18 occurrences. Dates and times are not changed automatically.
Under no circumstances will amounts charged for reservations that already exist be automatically changed.
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Scheduling Events from Recurring Masters

There are three primary ways to schedule events based on Recurring Masters. The best choice depends on the regularity of the schedule and 
whether the individual events’ details deviate from the master’s.

The “Add Event” Button

Use this method if you want to add a single event, or a series of irregularly scheduled events with the 
ability to change details (times, charges, locations, etc.) for each occurrence.

1. The Add Event button is located below the list of Recurring Masters. Select the master, 
then click the button.
2. A mini calendar opens. Select the date and click OK.

3. The Edit Event window opens with all the master’s details entered. 
Any of the details may be changed for this event. Save the Event record 
and you may take a reservation for it immediately.
You may also schedule from the main calendar.
Book’em!’s main calendar is available from the File menu, or by using the 
keyboard shortcut CTRL (Win) / Command (Mac) - B from anywhere 
in the program.
Select the day, and then the event definition from the Create New Event 
popup.
The Edit Event window will open and allow you to modify any of the 
master’s definitions.

Schedule by Calendar

Use this utility to schedule one or more events that will retain all of the details of the master.

Select ‘Schedule by Calendar’ from the Events menu at the 
Home screen. (Book’em!’s menus are specific to the frontmost 
window, each screen’s menus relate to the contents. The menus 
at the Home screen lead to other areas of the program.)
1. Click the date of the event you want to schedule to select 
it. 
Change the month from the month popup menu, or click the 
two arrows to move up (right arrow) or down (left arrow) one 
month.  The year may be changed by typing it in. After typing 
in a year, press the TAB key to make the Calendar change. If 
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any events are already scheduled for the selected day, they will be listed in the large open area.
2. Select the Event Master from the popup menu.
3. Click the ‘Create Event’ button once, or press the keyboard’s RETURN key.
Each time the ‘Create Event’ button is clicked an event is created with the characteristics of the currently selected Recurring 
Master. If you have many occurrences of this event type to enter, it is very fast to a) click the day with the mouse, b) press the 
RETURN key with your other hand.
When you are finished adding events of this type, you may select another from the popup and repeat until done.
And when you’re finished scheduling click Save to save all changes and return to the Home screen. Click Cancel to return 
Home and discard all changes.

Create Weekly Schedules

This is the tool to use if you offer regularly scheduled events that occur at least once per week for an extended period of time.

Choose ‘Create Weekly Schedules’ from the Events menu at the Home screen.

1. Select the event definition from the Event 
popup.
2. Select the day(s).
Each time a selection is made from the Day(s) 
popup, the selected day(s) are added to the list. If 
the event occurs more than once on a given day 
select the day again.
3. Any day may be selected and edited if any of the 
details differ from the master.
Maybe you offer a Tuesday special, or the start time 
varies by day-of-the-week, etc. Highlight the line 
and click Edit, or double-click the line.

4. Select the start and end dates. 
An event will be created for each line on the list for the ‘season’ defined by the 
(inclusive) start and end dates.
5. Click the ‘Schedule’ button Once.
Hundreds of events can be scheduled in a matter of seconds. But don’t create too 
many if you have an old, slow computer; it will just cause delays in building lists when 
a master is clicked at the Home screen.
6. When finished, Save or Cancel.
Either button will close the form and return Home. Use the Cancel button if you’ve 
made mistakes and wish to back out gracefully. If you do not click Save all of the 
created events will be discarded.

1
2

3

4
5

6

3



Book’em! QuickStart ....... 8

One-Time Events

A One-Time event is just what the name implies: a one-off that doesn’t fit any 
of your established templates. It could be a custom trip or party specially 
arranged to meet a client’s specifications. To avoid cluttering the list of Masters, 
use the One-Time Events option. 

The only difference between one-time and recurring events is the way they are 
organized and accessed. The reservation process is exactly the same.

Creation and Access

One-Time events are accessed from the Events menu at the Home 
screen, or CTRL (Win) / Command (Mac) - O. You have the option of 
having the One-Time Events List open automatically every time Book’em! starts up. Set this option in Preferences.
You may also create a One-Time event from the Quote Estimator. This is a powerful tool for determining pricing,
discounts, food, lodging, staff, and profit totals for a custom event. For detailed information on this tool see "Event
Quote Estimator" on page 89.
The time in the lower-left is the last time the information on the list was updated. This is of concern only if there are
other users taking reservations. The list is updated when the window is brought to the front, or by selecting the time
frame from the popup menu that’s next to the time indicator.
Use the ‘New Event’ button to add an event. Give it a distinctive name that you’ll recognize; if it’s a trip
commissioned by a customer, you may give the event the customer’s name (keep in mind this is the name that will
appear on customer’s confirmation letters, etc.). If an existing event is selected from the list the New Event button
becomes ‘Edit Event.’ This button will allow you to modify basic characteristics of the event, such as name, date, cost,
location, etc.
The event’s reservation screen may be opened by double-clicking the event or by selecting the event and clicking the
Select button. You may take reservations without opening that screen by selecting the event and clicking the ‘New
Reservation’ button.
On the other hand, if you organize a special event that may happen once or infrequently, but it is an important event
and when it’s over you’d like to be able to easily find everyone who attended, create a Master for it and use the ‘Not
Currently Offered’ checkbox in the Recurring Master record to have it not show on the list after the event is over.

Taking Reservations

The Reservations process is sequenced like a 
“Wizard.” Completing each step leads logically to 
the next. 

This makes it easy for you to train new users to 
take reservations.

1. Start the Reservations Process.
Select the event and click the New 
Reservation button.
There are New Reservation buttons on the 
Home screen, the Calendar and the One-
Time Events list. You can also start a new 
reservation by double-clicking the Event open 
and clicking the button there. The process is 

identical when started from any window. For any window where a New Reservation button exists, CTRL (Win) / Command 
(Mac) - N is the keyboard shortcut.

1
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The Reservation Creator opens.
2. Enter the number of people in this party.
If the number entered plus the number already sold puts the event over the defined limit, when you click the Reserve button 
you will be warned and given the options of overriding the limit, putting the party on the waitlist, or cancelling the reservations 
process. You can put a party on the waitlist even if the event is not full by clicking the Waitlist button.
The Reserve and Waitlist buttons are dimmed until a customer’s name is selected.
If you are running Book’em! on a network, a 
hold for the requested number of reservations is 
immediately placed to prevent inadvertent 
overbooking. When the reservation process is 
consummated or cancelled the hold is 
automatically released.
3. Try to find the guest in the Customer 
database.
It’s very important to avoid creating duplicate 
records. If there is any chance a record already 
exists in the Customer database for this person, 
try to find it and use it.
In the Search for Customer box, type all or part 
of the name of the reserving person. Enter last 
name <space> first name. Optionally, you may 
append a 5-digit zipcode. The number of letters 
that’s necessary to enter depends on how many 
records are in your Customer table and how 
common the name is. Once the search name is entered, the TAB key will search the database.
As you can see from the example above, entering John02466 will find everyone whose last name starts with John in the 02466 
zipcode. Entering Johnson R will find all Johnsons whose first name starts with R. This may seem counter-intuitive at first, but 
once you get used to it you’ll love it. Guaranteed.
You may click the Open button to check, add or modify information in their record. When you save the record you come back 
to the Reservation Creator.
4. If a record for this person does not already exist, click the New Customer Record button to create it.

Enter all of the person’s information in the 
appropriate fields. Use the TAB key to move 
from field to field.
Capitalization is automatic (unless you turn it 
off in Preferences), and telephone and credit 
card numbers format automatically (just enter 
the numbers).
Click the Detail tab to enter additional 
information about this customer. You can enter 
height, weight, diet & medical info, interests, 
and more. If any of these fields have data they 
will print on the trip’s roster.
When you save the new record you come back 
to the Reservation Creator.

5. Once the person’s record is shown in the list, 
click their name to select it.

If appropriate, mark the Fully Informed checkbox to indicate the guest has been informed of your company’s cancellation and 
liability policies. You may enter the policies in Preferences (File menu at the Home screen) and view using the Read button. Or 
you may choose to use this to indicate you’ve received a signed contract or liabilty waiver.
6. Click the ‘Reserve’ button.
The reservation is saved. Now you need to deal with the money.
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7. Book’em! creates an invoice and opens it.
You don’t need to actually invoice the customer; 
this is just the way charges and payments are 
managed.
8. Enter other charges or discounts.
From the Home screen, entries may be made to 
the ‘Equipment and Sale Items’ table (Databases 
menu), and added to invoices by using the New 
Item button. Also from Home, standard 
discounts may be entered with the Discount 
Editor (Financial menu) and applied to 
reservations by using the Add Discount popup. 
If other people in the party are being paid from 
this invoice, either click the ‘New Reservation’ 
button or change the quantity in the reservation 
line to the appropriate number. If others in the 
party will have their own invoice, you’ll be able 
to enter them after this invoice is saved.

9. If a payment is being made, click the Payment button.
Partial payments are OK. Click the payment type and add any notes regarding 
the payment.
10. Save the payment and the Invoice.
If the number of reservations charged is less than the number in the party, you’ll 
be asked to add them now. This request works just like the one described in #4, 
with the addition of the ‘Carryover Last Address’ option.
That’s it! You have just completed the process for taking a reservation. Once you 
have done this a few times it will be easy and very fast.

The Event/Reservations Window

This is the window that lets you view and control the details of an actual event and its reservations. Open the window by double-
clicking an event from any of these screens:

•  The Home screen
•  The Calendar
•  The One-Time Events List
•  The Reservation Finder
•  A Customer record’s History page 

1. The Event Title Button
The button containing the event’s name in the 
upper left opens the window that lets you edit 
the event’s definition: locations, cost, limit, 
times, etc. This is the same window that opens 
when the Edit Event button is clicked from the 
Home screen.
2. The Sponsor area
If this event has a sponsor, they’ll be shown 
here. A sponsor is billed for all or part of an 
event’s cost. This is the mechanism to bill a 
person or company who does not need a 
reservation for the event. Set up sponsorship from the Edit Event window, page 6.
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3. The New Reservation button
Creates a new reservation for this event. The process is described starting on page 8.
4. Reservations List
All people with reservations to this event are listed here, organized in parties and listed in the order their reservations were 
entered. The number of people in the party is shown in red to the left of the group’s ‘Kingpin.’

Double-click a reservation to open and edit the 
Reservation record, shown to the left. The person’s 
name is a button which opens their record. You may 
open the customer record directly from the 
reservations list by holding down the Shift key while 
double-clicking the reservation line.
Select a reservation to activate most of the buttons 
below the list. 
5. Reservation Columns
The 4 columns on the right side of the reservations 
list provide valuable information:
TP: Told Policy. This column is checked if the Fully 
Informed checkbox has been marked. This may be set 
while taking a reservation and in the reservation 

record.
PR: Printed. A checkmark (√) indicates a confirmation letter has been printed. 
CC: Credit Card. Shows a checkmark (√) if a valid number is on file and a question mark (?) if there is a number which 
couldn’t be validated. This is particularly useful if you hold reservations secured by a credit card.
PD: Paid status. Shows a checkmark (√) if the account is paid in full, a hyphen (-) if there’s a partial payment,  zero (0) if 
there’s an invoice with no charges, a plus sign (+) if overpaid, and a blank (   ) if the reservation is billed on another person’s 
invoice.
6. The Index Popup
A list of all people with reservations to this event in alphabetical order. Select a person to highlight their name. This is very 
useful for events with more than 20 or so reservations.
7. The Small Buttons
Invoice opens the invoice for the selected reservation.
Reschedule opens a list of upcoming events into which the selected reservation may be rescheduled.
Add to Party starts the reservation process and adds the new person to the selected party. The new person has his own invoice. 
To add to party and bill the new person to an existing invoice, open the invoice and use the New Reservation button.
Cancel Res cancels the selected reservation. Allows you to refund and/or credit the person’s account.
Hotel. If a reservation is selected and at least one hotel is defined for the event, the Hotel button lets you make room 
assignments and enter bed prefs. If a reservation is not selected, or if the Control (Windows) or Command (Mac) key is 
pressed, you receive the total of rooms needed and a breakdown by type, ie singles, doubles, etc. If no hotel is defined for the 
event the button is dimmed.
Verify checks all reservations and alerts you to any inconsistencies in the number of people in each party, any declared 
reservations that have not been billed, and any invoices that are past due.
Send to List opens the Customer database (see the next section, “Databases”) with this event’s customers in selection. Try it 
and notice all the commands that may be applied to the selection.
Payment lets you enter a payment without opening the invoice. Works only if the selected person has his own invoice.
Note lets you enter or modify a roster note for the selected person.
8. The Event Note Button
To enter or modify general notes for the event. Prints on the To Do list.
9. The To Do List Button
Lets you add and modify items for the To Do List. Each item may have a designated date and time, be assigned to a person 
from the Staff table, and have general notes.
10. The User Days Button
Quick check of user days for this event’s location for the month the event occurs in.



Book’em! QuickStart ....... 12

11. The Staff Area
The Staff button opens a window (shown to the 
right) which lists all staff people who are tagged 
as ‘Instructor’ (this designation tells the 
program which employees are eligible to work 
events). 
The Payroll process looks at these assignments 
and pay amounts to calculate totals. Designated 
staff appear atop rosters and can be referenced 
in confirmation letters.
If the staff person is assigned to work this event 
or any other event that overlaps this event, a 
checkmark is shown in the left column.
Select a staffer and see their address info, the 
events they’re scheduled to work during this 
time period, and their current certifications in 
the box to the right.
Select a staffer, enter a pay amount and/or 
commission, designate their job, and click the Select button. If the selected staffer is already working this event the Select 
button becomes Remove.
12. The Wait List Button
Opens the waiting list. Those waitlisted for this event are shown, but there is a popup that allows people waitlited for other 
events to be accessed and reserved. 
If a person calls who is on the waitlist for Event X, and wishes to do Event Y instead, open Event Y. Click the WaitList button 
and select This Event Type (if Event X and Y are the same type) or Entire Waiting List (if they are not) from the popup menu. 
Confirm their reservation from there.
13. The Print Button
Opens the Print Event window, shown below. You may choose to print any or all of the items shown.
The confirmation letter shown is the one selected in the Master or Event definition, but you may select any on the list to print, 
or write a new one. Click the Edit button to modify the letter. If you change the letter here it’s changed for the whole program.

If there is a map and/or directions entered in 
the Departure location’s record the Map and 
Directions checkboxes will be active. If the 
confirmation is sent as email, the map will be 
attached in jpeg format and the directions 
included in the body text.
The list of guests shows only those who have 
not yet had a confirmation printed. To print a 
letter for someone who has already had one 
printed click the Show All button. The primary 
reservers’ names are flush left and others in their 
party are indented.
The letter to the right of the names indicates 
whether the confirmation will be printed hard 
copy or sent as an email. Book’em! makes that 
determination based on settings in the customer 
records and whether the records contain valid 
email and/or physical addresses. 

You can send email to any customer whose record contains a valid email address by marking the Send Email if Email Address 
Exists checkbox. And you may print hard copy for any customer by holding down the Alt key (Windows) or Option key 
(Macintosh) and clicking the name.
You may select as many guests as you like to send the selected letter to. For contiguous selection click names with the Shift key 
down; for individual selection click with the CTRL (Win) / Command (Mac) - key down. The number just above the list of 
guests on the right shows the total letters/emails that will be processed.
In order to print confirmation letters the checkbox must be marked and at least one person must be selected.
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The Databases

The Database menu at the Home screen gives direct access to records in some of Book’em!’s data tables. 
Some of the items under the Financial menu also access main data tables: Receivables (opens Invoices 
with a balance due), Payroll Records, and Transactions (payments, refunds, payroll amounts).

In these areas you may (if appropriate to the data) add, modify, and delete records, import and export, 
create reports and graphs, send mail merge letters and manage mass mailings, and many other things.

The QuickSearch Window

When any item from the Database menu is selected the QuickSearch window opens. This 
allows you to tell Book’em! what records you want to find, or that you want to create a new record.

The available fields to search are different for each table. In most cases a 
“Starts With” search is the best option. If the field you want to search on 
is not available, click the Search Editor button for access to all fields and 
multiple criteria. When you use the Search Editor, any settings you may 
have made in the QuickSearch are ignored.
If you do not care that the list be sorted, and you suspect the number of 
records found will be large, turn AutoSort off.
The New Record button will let you create new records. Every time you 
save a record a new blank is created. When you are finished adding 
records, cancel the next blank. (the add-until-cancel feature may be 
turned off in Preferences by an Administrator.)

The List and Selections 

The window title of the data lists tells you how 
many records are in selection and how many 
records are in the table. In the example there are 
22,272 total Customer records and 14 in the 
current selection. Performing a search changes 
the selection.
You may also make a direct selection by single-
clicking records with the mouse. Hold down the 
Shift key and click any 2 records for a 
contiguous selection. Hold down the Control 
key (Windows) or Command key (Mac) and 
click to toggle selection of any single record on 
or off.
When you select an action item (Apply 
Keyword, Send Letter, Apply Mailing, Spool 
Labels, Add to Base Selection, Export, etc) 
from the menus, the action is applied to the 
records in selection unless you have made a direct selection with the mouse, in which case the action is applied to the direct 
selection. The exception to this is the Delete command, which is applied only to a direct selection.  A complete description of 
the many commands available from the list screen menus is beyond the scope of this QuickStart, but most are self-explanatory.
Double-click a record to open it for editing.

Creating Selections

The Search Editor, available from the Tools menu at all of the database list screens, allows you to select any field and specify a 
value to search for. You can add lines to query multiple criteria. Please see the accompanying document Search_Sort.pdf.
The Base Selection commands allow you to set up a “bucket” and add or remove the selections created by multiple searches.
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There are popup menus in the footer area of many data table list screens that change 
the current selection. The Staff, Companies, and Destinations table search by 
keyword, the Events table has a date range search (as well as a popup that lets you 
decide whether to open the Edit Event window or the Event/Reservations Window).
The popup for the Customer table has many options. You can find customers who 
have taken a certain event, or received a certain mailing, or qualify for a certain mailing 
list, or any of the other items.
When you make a selection from the customer list footer popup, holding down the 
Shift key causes the search to be done within the current selection. Holding down the 
Alt key (Windows) or Option key (Mac) searches for people who do not meet the 

selected criterion. The two keys may be held down in combination to remove those who do not meet the criterion from the 
current selection.

The Reservation Finder

CTRL (Win) / Command (Mac) - F opens the Reservation Finder from almost anywhere in Book’em! 

The Home screen indexes events by type; the Calendar indexes events by date. The Reservation Finder indexes them by participant - it 
does a fast search by customer name and shows you all their reservations. 

Also, it’s an ideal tool to use when adding new customer records. Do a search and, if the person is not found, click the New Customer 
button.

1. Type the name and TAB.

The search works just like the customer name request in the 
reservation process: the format is any amount of last name 
<space> first name + zipcode. Adding the zipcode is optional, 
but if you do add the zip it must be exactly 5 numeric 
characters.
After TABbing, the name box is highlighted again and 
another name may be entered. Remember, typing over 
highlighted text replaces the text.
2. Select the person to show reservations
After selecting the person, all of their past and future 
reservations are shown in the second list area (3) and general 
account info is shown in the lower text area (4). 
Select a reservation and the account info for that reservation is 
shown in the lower text area (4).
Double-click a reservation to open the Event/Reservation 
window for the event and highlight the reservation on that 
list.

Using the Finder to add new customer records

It’s extremely important to avoid entering duplicate records. There should be only one record for any person in your database. 
The Reservation Finder is a great tool to use to quickly search the customer database before adding a new record for a person 
not making a new reservation. If there’s any doubt about the spelling try variations, or just the first few letters of the last name 
plus zipcode.
When you’re sure there’s no existing record for this person, click the “New Customer” button, or CTRL (Win) / Command 
(Mac) - N.

1

2

3

4
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The Calendar

CTRL (Win) / Command (Mac) - K opens the Calendar from almost anywhere in Book’em! The Calendar shows all events occurring 
on a selected date, including multi-day events that started earlier.

The Calendar Key

Dates that have any event scheduled are shown in color.
Dates on which an event begins are shown in bold type.
Dates with appointments are underlined.
The selected date is darkened. All other sections of the Calendar screen pertain to the selected date.

Creating Events with the Calendar

Select the date (1), then select the event type from the Create New Event popup (2). The Edit Event window will open and 
allow you to modify any of the master’s definitions.

Tasks/Appointments

The Tasks/Appointments section shows reminders for users of the database, color-coded by priority. Appointments with 
customers, staff, contacts, etc. may be created here or by clicking the small Make Appointment icon in the individual records. 
(To-do items assigned to staff from event windows are not shown here.)
Marking a task “Completed” causes it to be removed from the list, unless “All” is selected from the popup. A setting made in 
Preferences causes uncompleted past tasks (except meetings) to be moved forward to the current date.

1

2
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Printing Reports and Letters

Wherever you go in Book’em! the menus relate directly to the content of the frontmost window. 
There are different menus for the Home screen, the database lists, database records, the event 
window, calendar, etc.

Use the Print command (File Menu) in the various locations to print pre-built reports based on 
the record(s) displayed. Use the Report Editor (Report Menu) to build you own reports based on 
the records displayed.

Reports

The Print command from the Home screen opens the report selector shown to the left. 
When a report is selected, you may then select the date or date range the report will 
include.
The Run Payroll command from the Financial Menu at the Home screen results in a 

printed report that itemizes and totals each employee’s assignments for the specified payroll period.
The Print command in Receivables results in a pre-built report containing the customer name, phone, event, and amount 
owed.
The Report Menu at the Event window contains a number of pre-built rosters and reports. Also, see "The Event/Reservations 
Window" starting on page 10, for a description of printing functions available there.
When the Print command is selected from the File Menu at any of the database lists, the records in selection are printed. See 
the earlier chapter "The Databases" starting on page 13 for info on creating selections. Also from any of the database list 
screens, the Report Editor (Report menu) may be used to build custom reports. Please see the accompanying document 
Reports_Labels.pdf for instructions on using the Report Editor.
When an individual record is opened from the database lists, use the Print command for a detailed printout.
The Calendar may be printed either as a graphical month or a daily listing of events or tasks.

Letters

Book’em! allows letters to be composed to anyone in the Customer, Staff, or Contacts database, using data specific to the 
person and the event they’re reserved into. They may be printed or sent as email. Confirmation letters may be sent from the 
Event window, and general mail merge letters from the database list screens. Any number of letters may be composed, named, 
saved, and used at any time.

General Mail Merge

Pictured to the right is the Mail Merge 
controller, which is accessed from the Send Mail 
command (File menu at the Customer List). 
The Mail Merge button from any customer 
record opens a simplified version.
The Smart Mailer feature examines each record 
to determine whether to print hard copy, send 
email, or do nothing. Following is a description 
of how the decision is made.
Every Customer record contains a Mail 
Preference setting. You may choose:

•  All Mail
•  All Except Promos
•  Confirmations Only
•  Don’t Send Anything

The same choice list is available on the 
Communications page of Preferences and will 
apply to customer records that have not been set manually.
The first thing Book’em! does is determine what kind of letter is selected. You may designate any letter as a Promo. If a Promo 
letter is selected, only customers tagged All Mail will be printed or emailed. (Confirmations are printed at the Event window.)
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Every customer record also contains a Mail Type setting. You may choose:
•  Email
•  Hard Copy

If the setting is made it will be used. If the setting is not made for the record, and the Send Email if Email Address Exists 
checkbox is marked, and the record contains a validated email address, Smart Mailer chooses email. If those conditions are not 
met, the physical address is examined and -- if it’s a valid address -- hard copy will be printed. If the address is not valid, 
Book’em! checks for a valid email address and sends email if present.
This sounds complicated, but it’s designed to make the appropriate choices without much user intervention.
Alternately, you may elect to use either the Print Hard Copy or Send Email modes and Book’em! will either send hard copy to 
all qualifying records in the selection with a valid physical address, or email to all with a valid email address.

Composing the Letter

This info pertains to both the standard text editor, 
and the 4D Write word processor.

Under the Merge Items menu are data that can 
be added to the letter. The merge item will be 
replaced with data specific to the record being 
printed. For example, the item <<Dear...>> will 
be replaced with Dear Bill, if no salutation is 
entered, or Dear Mr. Gates, if one is.
There is an area in Preferences for a default 
email subject, which will be used if none is 
saved with the letter.
If an existing letter is opened and modified and 
the name is changed, the letter is saved with the 
new name without deleting the original. This is 
equivalent to the Save As... command and is a 
way to use existing letters as templates. 

The Standard Text Editor

If you have not purchased the optional word 
processor module, you may compose the letter 
with the plain text processor, shown to the 
right.
You may set the font, size and style for the 
entire letter.
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If you have purchased the word processor module (shown above), font characteristics may be applied to selected text, and you 
have access to standard word processor functions like margins, tabs, indents, paragraph and character styles, etc.
Also, in addition to the Merge Items popup, there is direct access to all of the fields in the database: choose 4D Expression 
from the Insert menu.

Labels

One at a time labels

Book’em! provides a simple mechanism for printing individual mailing labels to a printer such as a Dymo (tested and 
recommended).
On the first page of Preferences, click the Label Printer Application button and select the software program that operates the 
printer.
When in a person’s record, click the Print Label button. The full address is copied to the clipboard, the label printer’s 
application is opened, and you can paste to the default label form.
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Label Spool

The concept behind the Label Spool is to allow you to accumulate records of 
people that you need labels printed for as you work, and also to consolidate all 
of the label printing tools in one place. If you are running Book’em! with 4D 
Server, labels from all users are sent to one spool so that one user may print 
all accumulated labels.

Records in any of the people tables may be sent to the Label Spool by clicking 
the Spool Label button in a record screen or by selecting records from a list 
screen and choosing Spool Labels from the File menu. There are Spool Label 
checkboxes in the Mail Merge and Apply Mailing dialogs. If the Preferences 
option is taken, new reservations will be automatically sent to the spool. 
Also, you may manually add people to the spool that do not have records 

elsewhere in the database.

To access the Label Spool, select it from the File menu.
Any names you have saved while working in other areas of the program are shown. You may convert any selection of records to 
ALL CAPS or Upper and Lowercase (Title Case) by choosing the appropriate command from the Tools menu.
Double-click a line to view or modify the formatted label.

Choose the printing format from the popup menu in the footer area of the Label Spool list, then one of 
the print commands from the File menu.
3x10 is the standard mailing label, will print to the standard Avery 5160 laser labels, 3 across by 10 
down.
Custom allows you to design a label using 4D’s Label Editor. See the accompanying document 
Reports_Labels.pdf for instructions.

Quick Reference

To create a one-time event

Choose ‘Create One-Time Event’ from the Events menu at the Home screen, or click the ‘New’ button on the One-Time 
Events List.

To open the One-Time Events List

Choose ‘One-Time Events List’ from the Events menu at the Home screen.

To open the Calendar

Choose ‘Calendar’ from the File menu, or command-K (Mac) control-K (Windows) from anywhere.

To enter a new reservation

Use the ‘New Reservation’ button that is available on the Home screen, the Calendar, and the One-Time Events List. The 
event must be selected from the shown list. Or, open the event’s record from any of these three ‘Launchers’ and use the ‘New 
Reservation’ button.

To add someone to an existing party

Open the event’s record. Select the maker of the party’s reservation and click the ‘Add to Party’ button. Or open the invoice 
and add from there.

To add someone to the Wait List

When you try to enter a reservation that would exceed the limit of an event, Book’em! will ask if you’d like to put them on the 
Wait List. (You may override the limit and book anyway, if you choose.) Or you may click the ‘Wait List’ button from the 
Reservation Creator (page 8).
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To move someone from the Wait List to a confirmed reservation

Click the ‘Wait List’ button from the event’s record. Select the person and click the ‘Confirm Reservation’ button.

To enter a payment for an existing reservation

Open the event’s record. Select the person making the payment and click the “Payment’ button. Or choose ‘Receivables’ from 
the Financial menu at the Home screen and double-click the person’s line. Unpaid reservations from all events are listed here.

To add a roster note to a reservation

Open the event’s record. Select the person and click the ‘Note’ button.

To reschedule a reservation to a different event

Open the event’s record. Select the person and click the ‘Reschedule’ button. Choose the new event from the list. Any 
payments will be transferred, and you’ll be asked if others in the party should be brought along.

To reschedule an entire event

Select the event from the list (center) at the Home screen. Click the ‘Edit Event’ button and change the date and/or times. 
Any existing reservations will stay with the rescheduled event.

To cancel a reservation

Open the event’s record. Select the person and click the ‘Cancel Res’ button.

To find a person’s existing reservation(s)

Command-F from anywhere opens the Reservation Finder

To create estimates for a client’s custom event

From the Financial menu at the Home screen, open Quote Estimator Defaults. For each of the items that may be used, enter 
the amount it costs to provide the service, and the profit margin you hope to earn. The profit margin is expressed as a 
percentage of the amount the client pays.
From a Customer record, click the Prepare Quote button and enter number of people, duration, etc. You may save any number 
of quotes for any customer. Any quote may be used to generate a One-Time Event.

To create and apply discounts for reservations

From the Financial menu at the Home screen, open Discount Editor. You may create standard discounts based on many 
criteria. If the discount is set to Auto-Apply, when creating a reservation, Book’em! examines the data and alerts you if the 
reservation is eligible. All saved discounts are available from a popup menu on the invoice and may be applied to any 
reservation.

To create an invoice not connected to an event or reservation

Open or create a customer record and click the New Invoice button.

To enter payments for multiple open invoices

From the Receivables list, select multiple invoices and click the Payment button. Each Payment window will open sequentially. 
See the chapter The Databases for tips on making multiple selections from a list.

To print trip lists and other reports

Several important reports may be accessed with the ‘Print’ command from the File menu at the Home screen. Others are 
available from the Report menu at the Event windows, and custom reports may be built at any primary list screen.

To print lists of people

Create a selection in the file you want to print from (see the User Guide) and choose ‘Print’ from the File menu at the List 
Screen.

To print mailing labels

Send records to the Label Spool by creating a selection of people and choosing ‘Spool Labels’ from the File menu at the file’s 
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List Screen, or by clicking the ‘Spool Label’ button in a person’s record. When printing letters, if the Send Address to Label 
Spool checkbox is marked, a label is spooled when the letter is printed as hard copy..

To import or export records

From the list screen of any of the databases, choose Import or Export from the File menu. The Export command exports the 
records in the current selection, which you control by query. The Import/Export editors let you choose the fields, delimiters, 
and formats for the procedure.
For more complex exports including data from related tables the Report Editor may be used. From the File menu, go to Print 
Destination and select Disk File.

To change the logged-in user without quitting the program.

Choose Log Off from the File menu at the Home screen. The program will not be able to be used until a user enters their 
password to enter.

General Hints & Tips

•  Back up your datafile regularly. On Macintosh the datafile is named Book’em!.data, on Windows it’s Book’em!.4DD.
•  Use an Uninterruptable Power Supply (UPS) for your computer (single-user) or server to prevent possible data corruption in 
the event of a power failure or brownout.
•  Move from field to field using the TAB key on the keyboard.
•  If the field you TAB into contains text, it is highlighted. If you type anything, you replace whatever was there before. This 
means you don’t need to swipe existing data to remove it, but it also means you should be careful not to delete valuable data. If 
you accidentally do this, use the Undo command from the Edit menu.
•  Buttons should only be clicked once. Never double-click a button.
•  Whenever an actual record is open for modification, there will be a Save, Cancel, and Delete button. All 3 will close the 
record. The Save button saves your changes, the Cancel button leaves without saving changes. Pressing Delete will 
permanently delete the record.
•  For records on a list: click once to select; click twice to open.
•  Many buttons won’t work until something is selected.  The general rule is to select records first, then choose the action.
•  Back up your datafile regularly. On Macintosh the datafile is named Book’em!.data, on Windows it’s Book’em!.4DD.

Dire Warnings

•  Never turn the computer off while Book’em! is running. Always quit Book’em! by selecting Quit or Exit from the File menu, 
or using the corresponding keyboard shortcut.
•  Use an uninterruptable power supply (UPS) with battery backup.
•  There are many ways that computer files can be damaged or lost. Power surges or failure, crashes, fire, theft are just a few. It 
is essential that you get into the habit of making regularly scheduled and properly stored archived backups. Back up whenever 
you’ve entered more data than would be convenient to re-enter. Never store backups on the computer! Store backups on 
removeable media such as CD-R, Zip or Tape. Keep a recent copy off-site, like in a safe deposit box. Using a compression 
program such as StuffIt or WinZip a datafile archive can be shrunk to 20%-25% of its full size. Never keep more than one 
uncompressed data file on your hard disk. Lost data could result from any confusion.
•  Avoid creating duplicate records.
•  Did we forget to mention? Back up your datafile regularly. On Macintosh the datafile is named Book’em!.data, on Windows 
it’s Book’em!.4DD.
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